注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

逍遥子 曰:

得失失得 何必患得患失 舍得得舍 不妨不舍不得

 
 
 

日志

 
 

常见Java开发过程中遇到的问题及其解决办法  

2014-09-28 13:44:17|  分类: JAVA |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

问题:

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/XXX/XXX/DDDD/service/Main : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method)

原因:

java程序在编译成字节码的时候使用的JDK和运行机子上的JDK不一致造成的,确切的说是:运行环境的JDK版本没有编译环境的JDK版本高

javaList转数组:

List<String> myList= new ArrayList<String>();
myList.add("hello java");
myList.add("hello c++");
myList.add("hello python");
String[] myArry = (String[])myList.toArray(new String[myList.size()]);

  评论这张
 
阅读(439)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017